RIM’s war on pre-OS 5.0 devices

At the recent BlackBerry Developer Day RIM repeatedly pointed out that (as the chart shows) 90% of paid applications were downloaded by users running OS 5.0 or higher. Again and again this point was brought up along with the recommendation that developers not bother coding for the older operating systems.

The question of course is why. The answer being that it allows RIM to get away from the perception that there is a lot of fragmentation in developing for BlackBerry, and that it allows BlackBerry applications to look nicer. Given that BlackBerry has been around a lot longer then iOS or Android many developers view working for BlackBerry as a larger task because of the need to support these legacy devices. RIM in turn is simply telling developers not to bother with the older devices, and figuring that well over a year after release, anyone not going to update to OS 5.0 or higher probably isn’t going to download any applications anyhow. Additionally this can help make BlackBerry applications look nicer as developers will be less afraid of using the newer APIs. If instead a developer decided that they needed to support a lowest common denominator of OS 4.5 they wouldn’t even have the decor APIs available to them, and would look awful.

RIM themselves has been holding true to this minimum of OS 5.0 by requiring this for things like the newest version of BBM, and the upcoming BlackBerry Bridge. Like all other developers RIM too can get more done if they only have to support OS 5.0 and newer devices.

The launch of Twinkle last summer was the first Ebscer application to require a minimum OS of 5.0 and since then Liar’s Dice and Xploiding Boxes have had the same requirement. Meanwhile others like the Call-A-Human application support OS 4.6.0 and higher but work much better when integrated with Universal Search on OS 6.0 devices.

The final message is that if you haven’t updated to OS 5.0 yet you are already missing out. If you haven’t updated to OS 6.0 yet you soon will be.